Jak scalić ułamek z tekstem w programie Excel

Ułamki to jeden z rodzajów liczb w programie Excel. Podczas bezpośredniego łączenia ułamka i tekstu za pomocą funkcja concat , ułamek zamienia się w liczbę z ułamkami dziesiętnymi, a format ułamka znika.

Na przykład w poniższym przykładzie podczas łączenia tekstu i ułamka „8%” zamienia się w „0,08”.

Aby scalić tekst i ułamek bez utraty formatu ułamka, użyj funkcja TEKST .



=TEKST(B2,'?/100')&' to '&A2

Gdzie TEKST(B2,'?/100') zachowa format ułamka.

Jeśli chcesz „10” jako mianownik, możesz zmienić 100 na 10.

TEKST(B2,'?/100') ma zachować format właściwego ułamka. Jeśli potrzebujesz frakcji mieszanej, skorzystaj z poniższego wzoru.

=TEKST(B2,'# ?/100')&' '&A2

Gdy frakcja jest większa niż 1, frakcja zamienia się we frakcję mieszaną. Na przykład „149/100” powraca do „1 49/100”.